Comment 28 for bug 1563184

Revision history for this message
Henry Wertz (hwertz10) wrote :

I wonder if this is a compiler error? Can anyone tell if Chromium for Ubuntu 14.04 and Chromium for 16.04 have different build flags, or if their configure scripts detect something different? To me, it seems like if they have the same or very similar build flags, 16.04 build breaks but 14.04 build doesn't, it implies gcc-5.4 is misbuilding something that gcc-4.8 isn't (or, much less likely, gcc-5.4 is building something correctly but chromium relies on some misbehavior of older gcc.)

I have an Acer Chromebook 13 (Tegra K1) which had 14.04 on it; Chromium 52 or 53 worked fine. Went to 16.04 (managing to hold back X so I could keep the nvidia driver...) and chromium blew up as others have reported.

I also found the 14.04 build of (at this point, chromium 53) worked fine after I set "--disable-namespace-sandbox"... I had the "Aw, snap!" but found (per google) that "--disable-namespace-sandbox" fixed it without the ill effects of "--no-sandbox".