json input link with calc->expr->pva not working

Bug #2031563 reported by Niko Kivel
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

The database below fails with
pvaLink void {anonymous}::pvaOpenLink(DBLINK*) fails MTEST-JSON:inp_json_calc: DBLINK* corrupt

system details:
linux x86_64
EPICS R7.0.7-DEV, as well as R7.0.7

record(ai, "MTEST-JSON:A1") {
    field(VAL, 1)
    field(PINI, 1)

record(ai, "MTEST-JSON:inp_json_calc") {
            "calc": {
                "expr": "A|B|C",
                "args": [
                        "const": 0
                        "pva": {
                            "pv": "MTEST-JSON:A1",
                            "proc": "CP"

Niko Kivel (niko-kivel)
description: updated
Revision history for this message
Niko Kivel (niko-kivel) wrote :

I confirmed this to be working on older versions, namely R7.0.6

Revision history for this message
Dirk Zimoch (dirk.zimoch) wrote :

Niko, I think it only worked in our (PSI) version where I, on your request, allowed special chars in pva names.

In modules/pvData/src/factory/FieldCreateFactory.cpp, function validateFieldName(), comment out the test for valid chars.

Revision history for this message
Niko Kivel (niko-kivel) wrote :

Hi Dirk

I tested it with a vanilla R7.0.6, here at CLS, and it works.
The modifications you made at PSI affected only the group names as far as I know.


Revision history for this message
Niko Kivel (niko-kivel) wrote :

I double checked, even with PV names consisting of capital letters only, the same error is produced using R7.0.7-DEV.

Revision history for this message
mdavidsaver (mdavidsaver) wrote :
Changed in epics-base:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.