Showing some load error in openstackclient --help

Bug #1481224 reported by cooldharma06
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Python client library for Zaqar
Fix Released
Victoria Martinez de la Cruz
Terry Howe

Bug Description

i installed openstakclient using from the git repository it working fine.

but when i run help command its showing some error code related to loading.

$ openstack --version
openstack 1.5.1

$ openstack -h

under Commands:

project create Create new project
project delete Delete project(s)
project list List projects
project set Set project properties
project show Display project details

Could not load EntryPoint.parse('queue_create = zaqarclient.queues.v1.cli:CreateQueue')
Could not load EntryPoint.parse('queue_delete = zaqarclient.queues.v1.cli:DeleteQueue')
Could not load EntryPoint.parse('queue_exists = zaqarclient.queues.v1.cli:CheckQueueExistence')
Could not load EntryPoint.parse('queue_get_metadata = zaqarclient.queues.v1.cli:GetQueueMetadata')
Could not load EntryPoint.parse('queue_list = zaqarclient.queues.v1.cli:ListQueues')
Could not load EntryPoint.parse('queue_set_metadata = zaqarclient.queues.v1.cli:SetQueueMetadata')
Could not load EntryPoint.parse('queue_stats = zaqarclient.queues.v1.cli:GetQueueStats')

quota set Set quotas for project or class


description: updated
Revision history for this message
Ayakashi (guowang) wrote :

i install with the same version 1.5.1 , but not reproduce the error...

Revision history for this message
cooldharma06 (cooldharma06) wrote :

steps to reproduce

i have my devstack setup

pip install python-openstackclient

then i ran this :
Traceback (most recent call last):
  File "/usr/local/bin/openstack", line 6, in <module>
    from import main
ImportError: No module named

so i download git clone git://xxxxxxxxxx/python-openstackclient.git

installed and ran the command

openstack -h

still i am getting the above error in my pc. !!

Revision history for this message
Terry Howe (thowe-g) wrote :

This is a Zadar issue

Terry Howe (thowe-g)
Changed in python-openstackclient:
status: New → Invalid
assignee: nobody → Terry Howe (thowe-g)
Changed in python-zaqarclient:
status: New → Confirmed
assignee: nobody → Victoria Martinez de la Cruz (vkmc)
Revision history for this message
Victoria Martinez de la Cruz (vkmc) wrote :

This was failing because of an outdated pdb version. It got fixed in this change

Changed in python-zaqarclient:
status: Confirmed → Fix Committed
importance: Undecided → Medium
Changed in python-zaqarclient:
milestone: none → 0.2.0
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.