savanna cluster-create ignores neutron_management_network parameter

Bug #1273500 reported by Matthew Farrellee
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Python client library for Sahara
Fix Released
High
Matthew Farrellee

Bug Description

cluster-create accepts a json representation of a cluster

the representation should closely match the output of cluster-show --json

it does except for the case of neutron_management_network

echo "{\"cluster_template_id\": \"$CLUSTER_TEMPLATE_ID\", \"default_image_id\": \"$IMAGE_ID\", \"hadoop_version\": \"1.2.1\", \"name\": \"cluster-instance\", \"plugin_name\": \"vanilla\", \"user_keypair_id\": \"$KEYPAIR_NAME\", \"neutron_management_network\": \"$NETWORK_ID\"}" | savanna cluster-create

results in a cluster w/o a neutron_management_network

+----------------------------+-------------------------------------------------+
| Property | Value |
+----------------------------+-------------------------------------------------+
...
| neutron_management_network | None |
...
+----------------------------+-------------------------------------------------+

which ultimately results in a failure to start the cluster

as seen in the api.log,

2014-01-27 19:25:31.481 18991 ERROR savanna.context [-] Thread 'cluster-creating-6efd857a-1f97-44f5-a5e5-4ff2884c8048' fails with exception: 'Bad network format: missing 'uuid' (HTTP 400) (Request-ID: req-267fde51-226d-4c33-bf39-63200b1d13d6)'

and in the cluster-show details,

+----------------------------+-------------------------------------------------+
| Property | Value |
+----------------------------+-------------------------------------------------+
...
| status | Error |
| status_description | Bad network format: missing 'uuid' (HTTP 400) |
| | (Request-ID: req- |
| | aef163f9-4ff7-4480-b719-c88379e3eeca) |
...
+----------------------------+-------------------------------------------------+

the issue is ClusterManager.create accepts the neutron_management_network through a parameter called net_id

Changed in savanna:
assignee: nobody → Matthew Farrellee (mattf)
importance: Undecided → High
milestone: none → icehouse-3
Revision history for this message
Matthew Farrellee (mattf) wrote :

fixed by -

commit fd777f1d2c219cc2e4adaf9b08d7b05be806a69a
Author: Matthew Farrellee <email address hidden>
Date: Mon Jan 27 20:06:01 2014 -0500

    Map neutron_management_network to net_id in CLI

    The JSON representation of a cluster uses neutron_management_network
    as a property name. The CLI allows for JSON injest, which is then
    translated into a ClusterManager.create call. The injest maps property
    names to parameter names to ClusterManager.create. This works in all
    cases except neutron_management_network, which is the net_id parameter
    to create.

    To address this, the CLI accepts neutron_management_network and maps
    it to the net_id parameter.

    Change-Id: I69799d0108740f0e79c82e45714fd946e9a2a4b0
    Closes-bug: #1273500

Changed in savanna:
status: New → Fix Committed
affects: savanna → python-savannaclient
Changed in python-savannaclient:
milestone: icehouse-3 → none
milestone: none → 0.5.0
Changed in python-savannaclient:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.