crash is crashy

Bug #2043804 reported by Benjamin Drung
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
coreutils (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

some description

ProblemType: Crash
DistroRelease: Ubuntu 24.04
Package: coreutils 9.4-3ubuntu6
Uname: Linux 6.8.0-31-generic x86_64
Architecture: amd64
Date: Tue May 21 11:25:05 2024
ExecutablePath: /tmp/tmpytxjc0gd/crash
PackageArchitecture: amd64
ShortGibberish: "]¶"
Signal: 11
SourcePackage: coreutils
Stacktrace:
 #0 0x0000555555555143 in f (x=42) at crash.c:3
         p = 0x0
 #1 0x0000555555555164 in main () at crash.c:6
 No locals.
StacktraceTop:
 f (x=42) at crash.c:3
 main () at crash.c:6
UserGroups: adm cdrom dialout dip docker libvirt lpadmin lxd plugdev sambashare sbuild sudo
separator:

Revision history for this message
Benjamin Drung (bdrung) wrote : Dependencies.txt
Revision history for this message
Benjamin Drung (bdrung) wrote : LongGibberish.txt
Revision history for this message
Benjamin Drung (bdrung) wrote : I can has a better retrace?

Stacktrace:
 long
 trace
StacktraceTop: ?? ()
ThreadStacktrace:
 thread
 even longer
 trace

Revision history for this message
Benjamin Drung (bdrung) wrote : good retrace!

Stacktrace:
 long
 trace
StacktraceTop:
 read () from /lib/libc.6.so
 foo (i=1) from /usr/lib/libfoo.so
ThreadStacktrace:
 thread
 even longer
 trace

Changed in coreutils (Ubuntu):
importance: Undecided → Medium
summary: - crash crashed with SIGSEGV in f()
+ crash crashed with SIGSEGV in read()
summary: - crash crashed with SIGSEGV in read()
+ crash crashed with SIGSEGV in f() on exit
Revision history for this message
Benjamin Drung (bdrung) wrote : good retrace with title amendment

Stacktrace:
 #0 0x0000555555555143 in f (x=42) at crash.c:3
         p = 0x0
 #1 0x0000555555555164 in main () at crash.c:6
 No locals.
StacktraceTop:
 read () from /lib/libc.6.so
 foo (i=1) from /usr/lib/libfoo.so

summary: - crash crashed with SIGSEGV in f() on exit
+ crash crashed with SIGSEGV in read() on exit
summary: - crash crashed with SIGSEGV in read() on exit
+ crash is crashy
Revision history for this message
Benjamin Drung (bdrung) wrote : good retrace with custom title

Stacktrace:
 #0 0x0000555555555143 in f (x=42) at crash.c:3
         p = 0x0
 #1 0x0000555555555164 in main () at crash.c:6
 No locals.
StacktraceTop:
 read () from /lib/libc.6.so
 foo (i=1) from /usr/lib/libfoo.so

Revision history for this message
Benjamin Drung (bdrung) wrote : tests

Stacktrace:

StacktraceTop:
 f (x=42) at crash.c:3
 main () at crash.c:6
ThreadStacktrace: "]¶"

Revision history for this message
Benjamin Drung (bdrung) wrote : StacktraceSource.txt
Revision history for this message
Benjamin Drung (bdrung) wrote : This bug is a duplicate

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #2043806, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Revision history for this message
Benjamin Drung (bdrung) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #2043807, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Revision history for this message
Benjamin Drung (bdrung) wrote : Possible regression detected

This crash has the same stack trace characteristics as bug #2043806. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer
tags: added: omgkittens
Changed in coreutils (Ubuntu):
status: New → Fix Released
status: Fix Released → New
tags: removed: need-amd64-retrace
tags: added: need-amd64-retrace
tags: removed: need-amd64-retrace
tags: added: apport-failed-retrace
tags: added: need-amd64-retrace
tags: removed: need-amd64-retrace
Changed in coreutils (Ubuntu):
status: New → Invalid
Revision history for this message
Benjamin Drung (bdrung) wrote : Crash report cannot be processed

I don't like you

Revision history for this message
Benjamin Drung (bdrung) wrote : Updated stack trace from duplicate bug 2043815

Package: coreutils 9.4-3ubuntu6
Stacktrace:
 #0 0x0000555555555143 in f (x=42) at crash.c:3
         p = 0x0
 #1 0x0000555555555164 in main () at crash.c:6
 No locals.

Revision history for this message
Benjamin Drung (bdrung) wrote : Dependencies.txt
Revision history for this message
Benjamin Drung (bdrung) wrote : ThreadStacktrace.txt
tags: removed: apport-failed-retrace
Revision history for this message
flin (flinandy59) wrote :

I am also facing the same software crash for my project https://gamingcy.com/. Any solutions?

Revision history for this message
flin (flinandy59) wrote :

I am also facing the same software crash for my project https://www.genera.cl/. Any solutions?

Revision history for this message
flin (flinandy59) wrote :

I am also facing the same software crash for my project https://www.fokawa.com/. Any solutions?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.