goa-daemon crashed with SIGABRT

Bug #1990200 reported by Cliff Carson
130
This bug affects 21 people
Affects Status Importance Assigned to Milestone
gnome-online-accounts
Fix Released
Unknown
gnome-online-accounts (Ubuntu)
Invalid
High
Unassigned
librest (Ubuntu)
Fix Released
High
Sebastien Bacher
Kinetic
Fix Released
Undecided
Unassigned

Bug Description

* Impact

The gnome-online-accounts sometime crash after resuming from suspend

* Test case

Install the librest update, restart your system and verify that configured online accounts keep working. Taking a Google account example, calendar events should show in gnome-calendar and the top panel widget, evolution should list your email account and nautilus should be able to browse your gdrive folder.

We should also confirm that error reports stop with the library update

* Regression potential

The patch makes the code better handle an empty payload. The librest rdepends in the archive are gnome-initial-setup/gnome-online-accounts/gnome-maps so we should verify that those keep working as expected.

-------------------------------------

Unknown cause of this crash. Was alerted to it after waking the system from sleep mode.

ProblemType: Crash
DistroRelease: Ubuntu 22.10
Package: gnome-online-accounts 3.45.2-3
ProcVersionSignature: Ubuntu 5.19.0-15.15-generic 5.19.0
Uname: Linux 5.19.0-15-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.23.0-0ubuntu2
Architecture: amd64
CasperMD5CheckResult: pass
CrashCounter: 1
Date: Mon Sep 19 19:26:29 2022
ExecutablePath: /usr/libexec/goa-daemon
InstallationDate: Installed on 2022-09-17 (2 days ago)
InstallationMedia: Ubuntu 22.10 "Kinetic Kudu" - Alpha amd64 (20220917)
ProcCmdline: /usr/libexec/goa-daemon
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: gnome-online-accounts
StacktraceTop:
 () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
 () at /lib/x86_64-linux-gnu/librest-1.0.so.0
 rest_proxy_call_sync () at /lib/x86_64-linux-gnu/librest-1.0.so.0
 () at /lib/x86_64-linux-gnu/libgoa-backend-1.0.so.1
Title: goa-daemon crashed with SIGABRT
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
separator:

Revision history for this message
Cliff Carson (ccarson1) wrote :
tags: removed: need-amd64-retrace
Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceTop.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in gnome-online-accounts (Ubuntu):
importance: Medium → High
Revision history for this message
Julian Andres Klode (juliank) wrote :

Impact:

I miss new events because I no longer get calendar notifications because the calendar does not sync anymore when that happens.

Revision history for this message
Sebastien Bacher (seb128) wrote :
tags: added: rls-kk-incoming
Changed in gnome-online-accounts (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-online-accounts:
status: Unknown → New
Changed in librest (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → Sebastien Bacher (seb128)
Changed in gnome-online-accounts (Ubuntu):
status: Triaged → Invalid
description: updated
description: updated
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package librest - 0.9.1-4

---------------
librest (0.9.1-4) unstable; urgency=medium

  * debian/patches/gitlab_goa_abort.patch: cherrypick a fix proposed upstream
    and already included in Fedora to fix gnome-online-account segfaulting
    sometime after suspend since libsoup3 (lp: #1990200)

 -- Sebastien Bacher <email address hidden> Tue, 22 Nov 2022 13:51:01 +0100

Changed in librest (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Cliff, or anyone else affected,

Accepted librest into kinetic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/librest/0.9.1-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-kinetic to verification-done-kinetic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-kinetic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in librest (Ubuntu Kinetic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-kinetic
Revision history for this message
Cliff Carson (ccarson1) wrote :

Unsure of librest update is installed correctly since I've never installed a package this way. The following dpkg -l shows the librest at 0.9.1.-2.

0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
cliff@cliffps:/etc/apt/sources.list.d$ dpkg -l | grep librest
ii librest-1.0-0:amd64 0.9.1-2ubuntu1 amd64

Will watch for the goa error.

Revision history for this message
Sebastien Bacher (seb128) wrote :

it seems installed correctly from that dpkg log yes, thanks for testing!

Revision history for this message
Jason Bryan (jwbryan) wrote :

Am impacted by this bug and testing this fix:

Performing actions...
(Reading database ... 287927 files and directories currently installed.)
Preparing to unpack .../librest-1.0-0_0.9.1-2ubuntu1_amd64.deb ...
Unpacking librest-1.0-0:amd64 (0.9.1-2ubuntu1) over (0.9.1-2) ...
Setting up librest-1.0-0:amd64 (0.9.1-2ubuntu1) ...
Processing triggers for libc-bin (2.36-0ubuntu4) ...
Press Return to continue, 'q' followed by Return to quit.

Will report back and mark bug appropriately.

Revision history for this message
Ivan Wolf (eiwaen) wrote :

I experienced this bug as well, so I updated to the proposed librest package (https://launchpad.net/ubuntu/+source/librest/0.9.1-2ubuntu1).

Revision history for this message
Ivan Wolf (eiwaen) wrote :

Since the update, I've suspended and woken up the computer numerous times, and I haven't seen the error once.

Revision history for this message
Paul Eichler (pleic) wrote :

I have seen the same bug pretty consistently. After upgrading (https://launchpad.net/ubuntu/+source/librest/0.9.1-2ubuntu1) it seems to be gone.
I will report if it shows up again

tags: added: verification-done verification-done-kinetic
removed: verification-needed verification-needed-kinetic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package librest - 0.9.1-2ubuntu1

---------------
librest (0.9.1-2ubuntu1) kinetic; urgency=medium

  * debian/patches/gitlab_goa_abort.patch: cherrypick a fix proposed upstream
    and already included in Fedora to fix gnome-online-account segfaulting
    sometime after suspend since libsoup3 (lp: #1990200)

 -- Sebastien Bacher <email address hidden> Tue, 22 Nov 2022 13:51:01 +0100

Changed in librest (Ubuntu Kinetic):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for librest has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in gnome-online-accounts:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.