Ubuntu Single Sign-On GUI not showing login button

Bug #1811596 reported by Erik Meitner
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Fix Released
gnome-online-accounts (Ubuntu)
unity-control-center (Ubuntu)

Bug Description

System Settings->Online Accounts->Ubuntu Single Sign-On

I can enter my email address and password abd select "I have an Ubuntu Single Sign-On account". But there is no "Save" or "Login" or any other button. I can only close the window.

Revision history for this message
Erik Meitner (e.meitner) wrote :

It seems that the buttons are missing.
My window:

Should look like this?:

Revision history for this message
Erik Meitner (e.meitner) wrote :

Ubuntu 18.04/amd64
unity-control-center 15.04.0+18.04.20180216-0u

I run unity-control-center from a shell, then I open Online ACcounts, then Ubuntu Single Sign-On. The following is displayed(six times):

(unity-control-center:2435): Gtk-WARNING **: 11:48:19.101: ../../../../gtk/gtkwidget.c:8584: widget not within a GtkWindow

Each time I open Ubuntu Single Sign-On an additional GTK warning is logged(1 the first time, two the second time, three the third.)

I enlarged the window to see if some controls were off the edge of the display area. Nope.

tags: added: bionic
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1811596/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Erik Meitner (e.meitner)
affects: ubuntu → unity-control-center (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Revision history for this message
Cigar Zh (cigarzh) wrote :

This bug seems like only in a unity session and the UI is normal in a ubuntu session.
Someone mentioned it there https://community.ubuntu.com/t/testing-unity-session-in-18-04/987/156

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

Upstream bug: https://gitlab.gnome.org/GNOME/gnome-online-accounts/issues/58

For workaround, run control center with csd enabled

GTK_CSD=1 unity-control-center

Changed in unity-control-center (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
Revision history for this message
Guy Sturino (gsturino) wrote :

I'm a new Linux user, but I started with Fortran in 1968. I don't usually get this stumped. I just signed in here to ubuntu single sign on with no problem. When I try to sign in through settings, I get a pop-up asking for authentication for Snap Daemon (it accepts my password) then there is a pop-up asking for authentication for keyring "Default. . . I don't recall being asked to set a password for this, but log in to ubuntu single sign on fails. In Windows I would scan the disk for errors, but I can't seem to find the right commands. I would appreciate any suggestions.

Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → Low
Revision history for this message
Jeevan Jyothish (blaocklight) wrote :

I had this problem last year and found a fix by asking here:


But when I tried logging in on a new installation today, it worked without enabling CSD. Maybe it got fixed? I'm using 18.04.2 now BTW

Revision history for this message
Sebastien Bacher (seb128) wrote :

Could well be a bug in gtk3-nocsd

Changed in gnome-online-accounts (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-online-accounts:
status: Unknown → New
Changed in gnome-online-accounts:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.