Comment 52 for bug 28052

Revision history for this message
In , Peter Hutterer (peter-hutterer) wrote :

(In reply to comment #37)
> Created an attachment (id=11756) [details]
> preliminary patch
>
> I chose option three: I applied your suggestion on cleanup in CloseDevice to
> init, and from the dix/ddx decoupling perspective I am quite satisfied now. The
> patch *DOES NOT WORK* but it shows how I intend to do it. However I need to
> modify ActivateDecice() or something like that. Are there any objections?
>

had a look at it on the last plane, looks good. One thing is left, which is more style than anything again: can you put accel stuff into a struct?
so that in the end we get something like
  dev->valuator->accell.clean()
  dev->valuator->accell.init()
instead of
  dev->valuator->AccelCleanupProc
  dev->valuator->AccelInitProc

I think it makes the code more readable. aside from that, I like it.