media button to disable touchpad not working

Bug #1826544 reported by Tim Tisdall
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
gnome-settings-daemon (Ubuntu)

Bug Description

I have an ASUS UX305CA laptop and after upgrading to 18.04 I am no longer able to disable the touchpad by hitting Fn+F9 . When I hit Fn+F9 it shows the graphic indicating that it's disabling the touchpad, but the touchpad continues to work. I tried using a LiveUSB copy of 18.04 and it the button works fine, so there seems to be something related to upgrading. I upgrading from 16.04 where it worked fine before.

I'm not sure which package to file this bug against, sorry.

Here are some details:

$ lsb_release -rd
Description: Ubuntu 18.04.2 LTS
Release: 18.04
$ lsmod | grep asus
asus_nb_wmi 28672 0
asus_wmi 28672 1 asus_nb_wmi
sparse_keymap 16384 1 asus_wmi
wmi 24576 1 asus_wmi
video 45056 2 asus_wmi,i915
asus_wireless 16384 0
$ dconf read /org/gnome/desktop/peripherals/touchpad/send-events

I also went through a diff between gsettings on the LiveUSB and my current install and nothing stood out to me as being related. I do have `org.gnome.desktop.interface gtk-im-module 'ibus'` which differs from LiveUSB which is set to 'gtk-im-context-simple', but I don't know if it's related.

Tags: bot-comment
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Revision history for this message
Tim Tisdall (tisdall) wrote :

I really have no idea what package to file this against because I don't know where the disconnect lies nor how to determine that. Please let me know what additional information is needed.

affects: ubuntu → gnome-settings-daemon (Ubuntu)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Does it work if you connect with another user? Could you also add your journalctl log to the bug after getting the issue

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Tim Tisdall (tisdall) wrote :

I'm not sure I understand your questions...

If you're asking if I have the same problem when logging in with a different user, then "yes" it also doesn't work when logging in with a 2nd account that's on my machine. That 2nd account existed before the upgrade to 18.04.

Also, the keys to disable the touchpad work fine on the login screen.

The only thing I see in journalctl is this:

Apr 29 10:43:47 zenbook org.gnome.Shell.desktop[3232]: Window manager warning: Overwriting existing binding of keysym 73 with keysym 73 (keycode 2f).

Revision history for this message
Sebastien Bacher (seb128) wrote :

Yes, that's what I was asking, weird bug... it might be worth reporting upstream on

Revision history for this message
Tim Tisdall (tisdall) wrote :

Help me with the history, though... I started on this machine with 15.10, then 16.04, and now 18.04. Wasn't 16.04 _not_ Gnome but Unity instead? This seems to be an issue with some left-over setting from 16.04 that's messing up 18.04. (unless it's something left over from 15.10)

There's so many layers that a keypress goes through that I'm lost as to where the issue should be reported. :(

I'll try reporting with Gnome and see if anyone has any ideas. Thanks for taking the time to look at this!

Revision history for this message
Tim Tisdall (tisdall) wrote :
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-settings-daemon:
status: Unknown → New
Changed in gnome-settings-daemon:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.